环境要求

本页面归纳了安装和使用 KubeSphere 的部分要求。

系统要求

系统最低要求(每个节点)
Ubuntu 16.04,18.04CPU:2 核,内存:4 GB,硬盘:40 GB
Debian Buster,StretchCPU:2 核,内存:4 GB,硬盘:40 GB
CentOS 7.xCPU:2 核,内存:4 GB,硬盘:40 GB
Red Hat Enterprise Linux 7CPU:2 核,内存:4 GB,硬盘:40 GB
SUSE Linux Enterprise Server 15 /openSUSE Leap 15.2CPU:2 核,内存:4 GB,硬盘:40 GB

依赖项要求

依赖项Kubernetes 版本 ≥ 1.18Kubernetes 版本 < 1.18
socat必须可选,但建议安装
conntrack必须可选,但建议安装
ebtables可选,但建议安装可选,但建议安装
ipset可选,但建议安装可选,但建议安装

容器运行时要求

支持的容器运行时版本
Docker19.3.8+
containerd(试验版,未经充分测试)最新版
CRI-O(试验版,未经充分测试)最新版
iSula(试验版,未经充分测试)最新版

网络要求

  • 请确保 /etc/resolv.conf 中的 DNS 地址可用,否则,可能会导致集群中的 DNS 出现问题。
  • 如果您的网络配置使用防火墙规则或安全组,请务必确保基础设施组件可以通过特定端口相互通信。建议您关闭防火墙。有关更多信息,请参见端口要求
  • 支持的 CNI 插件:Calico 和 Flannel。其他插件也适用(例如 Cilium 和 Kube-OVN 等),但请注意它们未经充分测试。

支持的 Kubernetes 版本

安装工具KubeSphere 版本支持的 Kubernetes 版本
KubeKeyv3.1.1v1.17.0, v1.17.4, v1.17.5, v1.17.6, v1.17.7, v1.17.8, v1.17.9, v1.18.3, v1.18.5, v1.18.6, v1.18.8, v1.19.0, v1.19.8, v1.19.9, v1.20.4, v1.20.6
ks-installerv3.1.1v1.17.x, v1.18.x, v1.19.x, v1.20.x

支持的 CSI 插件

Kuberentes 此前已宣布将在 1.21 版本中移除树内 (in-tree) 存储插件。有关更多信息,请参见 Kubernetes In-Tree to CSI Volume Migration Moves to Beta。因此,建议您安装 CSI 插件。

支持的 CSI 插件:

KubeSphere Web 控制台支持的浏览器

console-browser


感谢您的反馈。如果您有关于如何使用 KubeSphere 的具体问题,请在 Slack 上提问。如果您想报告问题或提出改进建议,请在 GitHub 存储库中打开问题。